https://dashboard.brex.com Outage

Incident Report for Brex

Resolved

A fix has been implemented and the Dashboard is now stable.
Posted 1 year ago. Mar 08, 2024 - 22:43 UTC

Update

A fix has been implemented and we are monitoring the results.
Posted 1 year ago. Mar 08, 2024 - 21:23 UTC

Monitoring

Dashboard availability has recovered. We are monitoring to ensure full recovery.
Posted 1 year ago. Mar 08, 2024 - 20:50 UTC

Investigating

Many customers are experiencing an issue with loading https://dashboard.brex.com. We are investigating and will update this page as we resolve the issue.
Posted 1 year ago. Mar 08, 2024 - 20:42 UTC
This incident affected: Dashboard.