Dashboard Partial Outage

Incident Report for Brex

Resolved

Functionality has been restored.
Posted Aug 26, 2025 - 00:59 UTC

Identified

Some customers may be experiencing issues loading expenses and wallet. Our team is aware of the issue and is actively working to correct it.
Posted Aug 25, 2025 - 22:53 UTC
This incident affected: Dashboard.