Operations Disruption Resolved

Incident Report for Brex

Resolved

We have resolved the issue that was affecting operations within our dashboard. All systems are now functioning as expected. Our team will continue to monitor performance closely to ensure operations continue normally.
Posted Aug 01, 2025 - 14:04 UTC

Investigating

We are investigating an issue that is affecting operations within our dashboard. Our team is actively investigating and working to resolve the problem as quickly as possible.
Posted Aug 01, 2025 - 13:48 UTC
This incident affected: Spend Management.