Brex Travel Outage

Incident Report for Brex

Resolved

This issue has been resolved.
Posted 6 months ago. Oct 03, 2024 - 22:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Oct 03, 2024 - 21:08 UTC

Update

Some customers are experiencing an issue with Brex Travel. We are investigating and will update this page as we resolve the issue.
Posted 6 months ago. Oct 03, 2024 - 20:33 UTC

Update

Some customers are experiencing an issue when booking a flight in co-pilot mode. We are investigating and will update this page as we resolve the issue.
Posted 6 months ago. Oct 03, 2024 - 20:32 UTC

Investigating

Some customers are experiencing and issue when booking a flight in co-pilot mode. We are investigating and will update this page as we resolve the issue.
Posted 6 months ago. Oct 03, 2024 - 20:19 UTC
This incident affected: Brex Travel.