Delays in incoming ACH processing

Incident Report for Brex

Resolved

We experienced some delays processing incoming ACH that have been resolved. We'll continue to monitor to ensure no further impact.
Posted 9 months ago. Jul 11, 2024 - 20:08 UTC

Investigating

We are experiencing delays processing incoming ACH at the moment. Our team is aware of the issue and is actively working to correct it.
Posted 9 months ago. Jul 11, 2024 - 19:13 UTC
This incident affected: Bill Pay.