Difficulty accessing the Brex dashboard

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Sep 29, 2025 - 11:55 UTC

Monitoring

We have identified the issue and have a fix in place.
Posted Sep 29, 2025 - 11:50 UTC

Investigating

We are currently investigating this issue.
Posted Sep 29, 2025 - 11:47 UTC
This incident affected: Dashboard.