Slow loading of activity logs and audit trail

Incident Report for Brex

Resolved

Activity logs and audit trail pages are stable.
Posted Apr 21, 2026 - 14:22 UTC

Monitoring

Activity logs and audit trail pages are loading normally again
Posted Apr 21, 2026 - 04:56 UTC

Investigating

Users may experience slow load times or timeouts when viewing activity on expenses, bills, users, cards in addition to the account audit trail. Other parts of the product remain unaffected. We'll share an update as soon as we have more information.
Posted Apr 21, 2026 - 04:24 UTC
This incident affected: Dashboard.