Dashboard Partial Outage

Incident Report for Brex

Resolved

We have resolved the issue.
Posted Mar 04, 2026 - 00:35 UTC

Monitoring

We have identified the issue and have a fix in place.
Posted Mar 03, 2026 - 23:19 UTC

Update

We have identified the issue and are working on a fix.
Posted Mar 03, 2026 - 22:20 UTC

Identified

We have identified the issue and are working on a fix.
Posted Mar 03, 2026 - 22:14 UTC
This incident affected: Dashboard.