Google SSO Outage

Incident Report for Brex

Resolved

Posted Sep 18, 2025 - 16:08 UTC

Investigating

We have received reports of an outage affecting Google. You may experience login issues if you use Google SSO.
Posted Sep 18, 2025 - 15:55 UTC